High latency and elevated error rates
Incident Report for Sezzle
Resolved
Service has been restored.
Posted Apr 22, 2021 - 17:21 UTC
Monitoring
We have implemented a fix and are actively monitoring. We expect services to recover shortly. We will continue to update this page with service status.
Posted Apr 22, 2021 - 17:00 UTC
Identified
We have identified the issue and are working on implementing a fix. We will post updates as soon as they are available.
Posted Apr 22, 2021 - 16:55 UTC
Investigating
We are currently experiencing elevated latency and error rates across our core services. We are actively working on diagnosing the issue. We will post updates as soon as they are available.
Posted Apr 22, 2021 - 16:47 UTC
This incident affected: Sezzle Gateway API and Sezzle Core API.