System outage

Incident Report for Sezzle

Resolved

This incident has been resolved.
Posted Aug 29, 2024 - 10:31 UTC

Update

The issue has been resolved.
Posted Aug 29, 2024 - 10:30 UTC

Update

We have identified the issue as due to an incident impacting our hosting provider, AWS. They report signs of recovery, and will provide updates within 30 minutes.
Posted Aug 29, 2024 - 09:56 UTC

Investigating

We are currently investigating an issue.
Posted Aug 29, 2024 - 09:37 UTC
This incident affected: Sezzle Gateway API, Sezzle Core API, and Sezzle Dashboards.